skip to Main Content

RouteSavvy User Guide – 1.3 – Browser Requirements

RouteSavvy has been designed to use the latest web features supported by all modern web browsers and requires an internet connection.

RouteSavvy has been tested with recent versions of the most popular browsers:

  • Internet Explorer 10 and 11
  • Edge
  • Chrome
  • Safari
  • Firefox.

Older browsers such as IE9 do not support the newer browser features and consequently will not work with RouteSavvy.

Like any web application, RouteSavvy’s performance is affected by the local system CPU and memory. If you are planning to work with a lot of addresses and multiple routes, it is recommended you use a newer and more powerful PC/Mac.

If you have questions contact RouteSavvy and/or request a live demo/support session.